Quantcast

OFDM MODULATION/DEMODULATION PROBLEM

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

OFDM MODULATION/DEMODULATION PROBLEM

Bilal
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OFDM MODULATION/DEMODULATION PROBLEM

Josh Blum-3


On 10/18/2012 04:47 AM, Bilal wrote:

> Hi
> I m using USRP2 and USRPN210 DB RFX900.
>
> Block diagram
> MOD:random source-->ofdm-->usrp sink
> DeMOD:usrp source-->ofdm demod-->>sink scope,fft
>
> Problem is that:
> Modulation is going fine,even at the receiver end the spectrum is just like
> it should be (block for OFDM )
> but there is nothing at the output of OFDM demod block Sink Scope is showing
> nothing. <http://gnuradio.4.n7.nabble.com/file/n38053/OFDM_DeMOD.png>
> <http://gnuradio.4.n7.nabble.com/file/n38053/OFDM_Mod.png>
> <http://gnuradio.4.n7.nabble.com/file/n38053/Spectrum.png>
> I have attached the mod,demod,received spectrum snaps.
> Help is highly appreciated...:-)
>

1 few things:

1) Remove the throttles, the sample rate is already throttled by the
usrp. There will be a fight.

2) I see an exception printed in the GRC window for one of the
screenshots. That might be important to share?

3) The random source should probably be 0 to 1 << 32. I believe thats a
32 bit integer stream. Things might not work as expected when the input
bits are mostly 0.

-josh

_______________________________________________
Discuss-gnuradio mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OFDM MODULATION/DEMODULATION PROBLEM

Bilal
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: OFDM MODULATION/DEMODULATION PROBLEM

Josh Blum-3


On 10/19/2012 05:09 AM, Bilal wrote:
> 1)removed still no output...:-(
>
> 2)thread[thread-per-block[0]: <gr_block gr uhd usrp source (12)>]: caught
> unrecognized exception
>
> i think this is not an error as it appears when i close the window....
>

That might be ok. I think its a boost issue on ubuntu 10.04. So I am
guessing this is ubuntu 10.04, but i could be wrong :-)

> 3) i have connected scope with random source to see transmitted integers
> still no output at receiver.
> (tried even simple sin wave).
>

The scope sink is working for you, right? No some weird OpenGL freezing
issue. If you make a simulation only flow graph like noise_source
->throttle->scope sink, you see the noise?

I suppose the first thing to do before transmitting OFDM would be to
verify the RX chain with some simple test tones. Is the antenna
selection correct, power levels, etc. Does the daughterboard report
locked when tuned?

-josh

PS: some of the uhd examples liek ascii_art_dft automatically check for
dboard lock; hope that helps

_______________________________________________
Discuss-gnuradio mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
Loading...