Quantcast

GNURadio looking for wrong boost version

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

GNURadio looking for wrong boost version

rmsrms1987
This post was updated on .
Hi Everyone,

This might be something very trivial that I am unsure how to fix.  I had everything with GNURadio working up until a couple days ago, but this afternoon I was getting some error concerning boost when trying to import one of the libraries.  In particular, when providing the command:

from gnuradio import gr

I receive the following error:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib64/python2.7/site-packages/gnuradio/gr/__init__.py", line 27, in <module>
    from gnuradio_core import *
  File "/usr/local/lib64/python2.7/site-packages/gnuradio/gr/gnuradio_core.py", line 23, in <module>
    from gnuradio_core_runtime import *
  File "/usr/local/lib64/python2.7/site-packages/gnuradio/gr/gnuradio_core_runtime.py", line 26, in <module>
    _gnuradio_core_runtime = swig_import_helper()
  File "/usr/local/lib64/python2.7/site-packages/gnuradio/gr/gnuradio_core_runtime.py", line 22, in swig_import_helper
    _mod = imp.load_module('_gnuradio_core_runtime', fp, pathname, description)
ImportError: libboost_filesystem.so.1.52.0: cannot open shared object file: No such file or directory

I am not sure what has changed on my computer, but I have not updated boost.  Now it is for some reason looking for the wrong version (I have version 1.49).  Instead of recompiling the GNURadio, is there any quick fix for this?

Thanks,
Rob
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GNURadio looking for wrong boost version

Tom Rondeau-2
On Tue, Jul 23, 2013 at 6:42 PM, rmsrms1987 <[hidden email]> wrote:

> Hi Everyone,
>
> This might be something very trivial that I am unsure how to fix.  I had
> everything with GNURadio working up until a couple days ago, but this
> afternoon I was getting some error concerning boost when trying to import
> one of the libraries.  In particular, when providing the command:
>
> from gnuradio import gr
>
> I receive the following error:
>
> Traceback (most recent call last):
>   File "<stdin>", line 1, in <module>
>   File "/usr/local/lib64/python2.7/site-packages/gnuradio/gr/__init__.py",
> line 27, in <module>
>     from gnuradio_core import *
>   File
> "/usr/local/lib64/python2.7/site-packages/gnuradio/gr/gnuradio_core.py",
> line 23, in <module>
>     from gnuradio_core_runtime import *
>   File
> "/usr/local/lib64/python2.7/site-packages/gnuradio/gr/gnuradio_core_runtime.py",
> line 26, in <module>
>     _gnuradio_core_runtime = swig_import_helper()
>   File
> "/usr/local/lib64/python2.7/site-packages/gnuradio/gr/gnuradio_core_runtime.py",
> line 22, in swig_import_helper
>     _mod = imp.load_module('_gnuradio_core_runtime', fp, pathname,
> description)
> ImportError: libboost_filesystem.so.1.52.0: cannot open shared object file:
> No such file or directory
>
> I am not sure what has changed on my computer, but I have not updated boost.
> Now it is for some reason looking for the wrong version.  Instead of
> recompiling the GNURadio, is there any quick fix for this?
>
> Thanks,
> Rob

Have tried running ldconfig to reset things (as root/sudo)?

Tom

_______________________________________________
Discuss-gnuradio mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
Loading...